1. Welcome to the new home for MySportTrac.com!

    Please click here to find all the info about the move to the new site!

    To access your account you will need to reset your password here

Had a fire...

Thread in 'Engine' started by Matt Becker, Oct 19, 2019.

  1. Matt Becker

    Matt Becker Member 1st Gen Owner 4 Wheel Drive V6 Engine

    Messages:
    1
    Likes Received:
    0
    Joined:
    Oct 19, 2019
    Location:
    Manhattan, KS
    So, I replaced all the timing chains, tensioners, etc in my '01 Sport Trac 4.0...get it stuck back in, everything hooked up and started it.

    It ran about 4 seconds, sputtered, and proof. Fire.

    Found a bad o-ring road that fed the fuel rail and was spraying gas all around. Anyway, got the fire out and not much damage at all...except, the pcv tube was melted, and some of the vacuum lines were melted. Found the pcv tube...but I can't find these damn vacuum lines, anywhere. Ford couldn't even pull them up...granted, the local guy is new, but couldn't find them.

    Anyone have a part number? It's the offset line that runs from the intake, rolls around behind the intake, etc.

    I can post a pic if needed.

    Thanks in advance!!!
     
  2. Todd Z

    Todd Z Well-Known Member 2nd Gen Owner V6 Engine V8 Engine

    Messages:
    20,923
    Likes Received:
    157
    Joined:
    Sep 21, 2003
    Location:
    Suffolk County (Long Island), NY
    Only the PCV line comes complete.... the rest you may need to us universal stuff... nothing like that is available any more... trucks 18 years old.... or junk yard.
     

Share This Page