1. Welcome to the new home for MySportTrac.com!

    Please click here to find all the info about the move to the new site!

    To access your account you will need to reset your password here

My electrical issues.

Thread in 'Electrical - General' started by Chris McCauley, Mar 22, 2018.

  1. Chris McCauley

    Chris McCauley Member

    Messages:
    5
    Likes Received:
    2
    Joined:
    Jan 25, 2018
    Location:
    Carrollton,Tx
    When I bought the truck the lightbulb for the gas gauge and the speedometer was out. A last week I replace them and after that I started having weird problems with my instrument cluster. The engine light or the traction control light would come on and tell me there's a problem but everything else works fine. It didn't seem to affect the truck. I could just turn off the engine turn it back on and be back to normal. That went on for about a 3 days. Then everything was fine. Well this morning I noticed that the tach has stopped working. Checked all the fuses checked everything I could think of. I'm not sure why it stopped working.
     
    Last edited: Mar 22, 2018
  2. EddieS'04

    EddieS'04 Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    17,001
    Likes Received:
    48
    Joined:
    Sep 26, 2004
    Location:
    Pasadena, TX
    A weak battery can cause electrical gremlins in the '01 to '05 Tracs'
    I would go back and check your cluster connectors. If all this started after bulb replacement. Also make sure the bulbs were correct. There could be a resistance problem with a wrong bulb.
     

Share This Page