1. Welcome to the new home for MySportTrac.com!

    Please click here to find all the info about the move to the new site!

    To access your account you will need to reset your password here

Why is my side mirrors not working?

Thread in 'Electrical - General' started by James Sniezek, Nov 28, 2011.

  1. James Sniezek

    James Sniezek Active Member 1st Gen Owner V6 Engine

    Messages:
    189
    Likes Received:
    0
    Joined:
    Nov 15, 2006
    Location:
    Watsontown, PA
    My side mirrors stop working. They both stop working. :cry:
     
  2. James Easley

    James Easley Active Member

    Messages:
    126
    Likes Received:
    0
    Joined:
    Aug 12, 2011
    Location:
    Cincinnati, OHI
    Same. Would like to know also
     
  3. TRACket Paul

    TRACket Paul Well-Known Member 1st Gen Owner V6 Engine

    Messages:
    2,360
    Likes Received:
    0
    Joined:
    Aug 4, 2003
    Location:
    Sacramento, CA
    Check the 5 amp fuse, 2.1, in the Central Junction Box.



    [Broken External Image]:
     
  4. James Sniezek

    James Sniezek Active Member 1st Gen Owner V6 Engine

    Messages:
    189
    Likes Received:
    0
    Joined:
    Nov 15, 2006
    Location:
    Watsontown, PA
    I check the fuse it is ok. :/
     
  5. EddieS'04

    EddieS'04 Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    17,280
    Likes Received:
    106
    Joined:
    Sep 26, 2004
    Location:
    Pasadena, TX
    Try cleanin the contacts on the switch. Or replacing it.

    You can also use a jumper when the switch is out. See if the mirrors work. Use a vom to determine which contact is the 12vdc power. jump from there to other conections.



    If they still dont work. Or if there is no 12vdc. There is a breakdown in the door wiring.
     
    Last edited by a moderator: Nov 28, 2011
  6. James Sniezek

    James Sniezek Active Member 1st Gen Owner V6 Engine

    Messages:
    189
    Likes Received:
    0
    Joined:
    Nov 15, 2006
    Location:
    Watsontown, PA
    ok I will try that out.
     
  7. OFF TRAC

    OFF TRAC Active Member 1st Gen Owner V6 Engine

    Messages:
    366
    Likes Received:
    0
    Joined:
    Nov 14, 2005
    Location:
    Austin & Eagle Pass, TX
    Check the rubber boot that covers the wires going into the door (when you open the driver side door) My '02 had both mirrors stop working. It was a pinched wire inside the rubber boot that caused them to stop. The wire in question is (at least on my '02) a light orange with black stripe on it. I just cut the pinched area connected it back with electrical tape and they started working again. Going on 6 years since "repair" w/out any problems.
     
  8. James Easley

    James Easley Active Member

    Messages:
    126
    Likes Received:
    0
    Joined:
    Aug 12, 2011
    Location:
    Cincinnati, OHI
    Still a no go for me. Should I just take it in?

    :sad:
     

Share This Page