1. Welcome to the new home for MySportTrac.com!

    Please click here to find all the info about the move to the new site!

    To access your account you will need to reset your password here

Transmission slipping in reverse?

Thread in 'Automatic Transmission' started by Tim Mason, Apr 6, 2019.

  1. Tim Mason

    Tim Mason Member

    Messages:
    45
    Likes Received:
    0
    Joined:
    Sep 18, 2002
    Location:
    Longmont, CO
    Recently I noticed that my transmission is slipping in reverse? No notable issue in Drive.
    2002, well maintained, 175k. I tightened up the servo valve several years ago during a pan drop/filter change. Royal Purple fluid and regular filter/oil changes. Any ideas before I have a shop check it out?
     
  2. Paul Fithian

    Paul Fithian Member 2nd Gen Owner 2 Wheel Drive V8 Engine

    Messages:
    42
    Likes Received:
    18
    Joined:
    Dec 15, 2016
    Location:
    Long Beach, IN
    I had a similar issue, weak reverse, all other gears were fine.

    I replaced the valve body with a Shift-Rite, now it works like new.
     
  3. EddieS'04

    EddieS'04 Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    17,224
    Likes Received:
    99
    Joined:
    Sep 26, 2004
    Location:
    Pasadena, TX
    Paul may have a good point on the valve body. As far as a pan drop and fluid. I would not have mixed the royal purple with the motorcraft mercon 5. Most of the fluid is in the torque convertor. When I do a pan drop on my '04 I go back with the motorcraft merc5...
     
  4. Paul Fithian

    Paul Fithian Member 2nd Gen Owner 2 Wheel Drive V8 Engine

    Messages:
    42
    Likes Received:
    18
    Joined:
    Dec 15, 2016
    Location:
    Long Beach, IN
    Use only Mercon V in the 5R55E transmission.
     
  5. EddieS'04

    EddieS'04 Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    17,224
    Likes Received:
    99
    Joined:
    Sep 26, 2004
    Location:
    Pasadena, TX
    DITTO, mercon v or mercon 5, same stuff. I prefer to stick with the motorcraft brand.
    I have a tune on my trans plus I manually turned up the epc. No problems yet.
     

Share This Page