1. Welcome to the new home for MySportTrac.com!

    Please click here to find all the info about the move to the new site!

    To access your account you will need to reset your password here

Start Up Idle Seems High

Thread in 'Performance' started by Garry Moss, Feb 2, 2018.

  1. Garry Moss

    Garry Moss Active Member 1st Gen Owner V6 Engine

    Messages:
    274
    Likes Received:
    0
    Joined:
    May 24, 2010
    Location:
    San Pablo, CA
    hey Peeps

    My 04 ST has been idleing up around 2500 during start up, during cold and warm. Seems to take awhile for it to come down. I did replace the IAC a few weeks ago but this just started yesterday. Any ideas?
     
  2. swshawaii

    swshawaii Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    4,910
    Likes Received:
    10
    Joined:
    Feb 27, 2009
    Location:
    Kailua-Oahu, Hawaii
    Normal for mine too, although only up to about 2k, then settles down to about 700 revs within 5 seconds. Probably wouldn't hurt to clean the throttle body and spray the MAF sensor filaments with the specific CRC cleaners if you haven't done it yet. GL
     
  3. Garry Moss

    Garry Moss Active Member 1st Gen Owner V6 Engine

    Messages:
    274
    Likes Received:
    0
    Joined:
    May 24, 2010
    Location:
    San Pablo, CA
    Its seems to stay at 2500 rpm for awhile. I just had it smogged, would they have disconnected anything that maybe they didnt put back?
     
  4. swshawaii

    swshawaii Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    4,910
    Likes Received:
    10
    Joined:
    Feb 27, 2009
    Location:
    Kailua-Oahu, Hawaii
    Only thing I can think of is the breather tube connected to the intake hose by the MAF and air box. I'd scan for stored trouble codes in memory regardless whether you have a check engine light or not. High idle started right after emissions check? Mine threw a CEL with a "P0507 Idle Control System RPM Higher Than Expected" code ONE time, but I cleared it, and never happened again.
     
  5. EddieS'04

    EddieS'04 Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    16,851
    Likes Received:
    7
    Joined:
    Sep 26, 2004
    Location:
    Pasadena, TX
    If you dont find an intake leak. Try when motor is cold. Disconnect the neg batt cable for 10 minutes. Then start it and let it idle until the idle is normal, before driving it.
     

Share This Page