1. Welcome to the new home for MySportTrac.com!

    Please click here to find all the info about the move to the new site!

    To access your account you will need to reset your password here

No heat help please

Thread in 'Help Forum' started by Ty Meyer, Jan 4, 2020.

  1. Ty Meyer

    Ty Meyer Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Nov 16, 2015
    Location:
    , TN
    I have a 2001 ford explorer sport trac. Im still new to all of this.I had my heater core replaced, because I had fumes and smell coming through vents inside. There is no smell but my heat is still not working. What do I need to do?
     
  2. Richard McAlister

    Richard McAlister Active Member 2nd Gen Owner V8 Engine

    Messages:
    485
    Likes Received:
    2
    Joined:
    Apr 20, 2008
    Location:
    Collinsville, OK
    Sounds like you have trapped air in the system. You might try taking the radiator cap off and running it for a while at idle. Be use that the heater is on and at full hot.
     
    swshawaii likes this.
  3. swshawaii

    swshawaii Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    5,122
    Likes Received:
    82
    Joined:
    Feb 27, 2009
    Location:
    Kailua-Oahu, Hawaii
    ^ Good advice. Parking uphill while running the engine "may" also help purge air from the cooling system.

    Repeatedly squeezing the upper hose with the cap off and engine at operating temp seems to help "burp" air, at least for me.
     
  4. Ed Fenwick

    Ed Fenwick Well-Known Member 1st Gen Owner

    Messages:
    829
    Likes Received:
    5
    Joined:
    Dec 28, 2008
    Location:
    Kea'au, HI
    try feeling the inlet heater hose to see if it is hot.
     
  5. Todd Z

    Todd Z Well-Known Member 2nd Gen Owner V6 Engine V8 Engine

    Messages:
    20,993
    Likes Received:
    173
    Joined:
    Sep 21, 2003
    Location:
    Suffolk County (Long Island), NY
    UGH,,,, if you park up hill and have air trapped and the water pump doesn't get water, POOF smoked motor !!
    Feel both hoses when the trucks warm, are they the same??
    Check the heater valve to make sure its not broken and functions. The 01 is buried by the belt tensioner next to the water pump. has small black and grey plastic lines going to it.

    Check coolant level in the radiator when COLD.. NOT THE BOTTLE... there could be air.

    How does the engine temp gauge sit? could be bad stuck thermostat.
     
  6. swshawaii

    swshawaii Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    5,122
    Likes Received:
    82
    Joined:
    Feb 27, 2009
    Location:
    Kailua-Oahu, Hawaii
    OK, so DON'T park uphill while running the engine or you may "poof" the engine. LOL
     
    Todd Z likes this.

Share This Page