1. Welcome to the new home for MySportTrac.com!

    Please click here to find all the info about the move to the new site!

    To access your account you will need to reset your password here

  1. Mark Stadnicki

    Mark Stadnicki Well-Known Member 2nd Gen Owner V6 Engine

    Messages:
    918
    Likes Received:
    4
    Joined:
    Oct 3, 2007
    Location:
    Mechanicsville, MD
    I know I seen it on Facebook but now can't find it.

    2010 V6 limited 4WD 167k miles- my auto climate system acts like it stops/slows blowing air when I put load on engine. Let off or normal driving works good. I thought I read it's a vacuum item under the hood?

    New Ranger Raptor can't get to the US fast enough, lol
     
  2. Mark Stadnicki

    Mark Stadnicki Well-Known Member 2nd Gen Owner V6 Engine

    Messages:
    918
    Likes Received:
    4
    Joined:
    Oct 3, 2007
    Location:
    Mechanicsville, MD
    Thanks swhawaii, I didn't realize it was that common of a problem. I guess I should of Googled it ;)
     
    swshawaii likes this.
  3. Todd Z

    Todd Z Well-Known Member 2nd Gen Owner V6 Engine V8 Engine

    Messages:
    20,572
    Likes Received:
    71
    Joined:
    Sep 21, 2003
    Location:
    Suffolk County (Long Island), NY
    I also posted about this.... Little vacuum check valve under the hood....
     
  4. EddieS'04

    EddieS'04 Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    17,054
    Likes Received:
    63
    Joined:
    Sep 26, 2004
    Location:
    Pasadena, TX
    I had dodge that did the same. I just got a generic check valve, that was the same nipple size, from O'rielys'. I think it was $3...
     
  5. Mark Stadnicki

    Mark Stadnicki Well-Known Member 2nd Gen Owner V6 Engine

    Messages:
    918
    Likes Received:
    4
    Joined:
    Oct 3, 2007
    Location:
    Mechanicsville, MD
    Got one ordered, thanks all!
     
    Todd Z likes this.

Share This Page