1. Welcome to the new home for MySportTrac.com!

    Please click here to find all the info about the move to the new site!

    To access your account you will need to reset your password here

Anti lock brake issues? problem when stopping,

Thread in 'Maintenance / Service' started by Dave Felker, Mar 13, 2018.

  1. Dave Felker

    Dave Felker Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Aug 9, 2009
    Location:
    Fowler, IL
    I have an '02 ST Recently when I apply the brakes and I'm almost completely stopped, the brake peddle goes farther down and it sorta feels like the right front tire is sliding on ice.
    ( no ice there)It just does it once in awhile.Not consistant. And it seems like it does it more when the whells are turned but sometimes when straight.
    I'm guessing this is anti-lock brakes. Anybody got any ideas?
     
  2. Todd Z

    Todd Z Well-Known Member 2nd Gen Owner V6 Engine V8 Engine

    Messages:
    20,349
    Likes Received:
    21
    Joined:
    Sep 21, 2003
    Location:
    Suffolk County (Long Island), NY
    probably a bad hub bearing going bad if your 4wd..... Does it seem to pull to one side too??? have a shop check the front end. Please update your info so we know what truck you have
     
  3. GENE LYONS

    GENE LYONS Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Feb 15, 2012
    Location:
    E. PEORIA, IL
    I have a 02 Sport Trac 4x4 with ABS brakes and this winter a couple of times when in snow the brake pedal would go down as usual and then go down more and seemed like abs kicked in but brake stayed lock on. I haven't had it checked yet, but thought someone has had problem and found the problem. Was yours like I said? Good luck as I am going to try to find a fix. GENO
     
  4. Dave Felker

    Dave Felker Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Aug 9, 2009
    Location:
    Fowler, IL
    I'll have that hub bearing checked out. ...No, it does not pull at all. The Brakes are OK except at almost a full stop. Thanks
     

    Attached Files:

  5. Dave Felker

    Dave Felker Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Aug 9, 2009
    Location:
    Fowler, IL
    Mine does it on dry pavement. Not all the time, more when the wheel is turned.
    If you find out anything more, Please let me know. Thanks, Dave
     
  6. RON LAPOINTE

    RON LAPOINTE Member 1st Gen Owner V6 Engine

    Messages:
    45
    Likes Received:
    0
    Joined:
    Oct 31, 2000
    Location:
    EASTHAMPTON, MA
    Are you feeling pulsing, if yes its definitely the abs, and its usually one of the front hubs needs replacement. I replaced both of mine on my 01 trac to fix the issue, after trying the abs sensor on the rearend.
     

Share This Page